Ticket #151 (closed enhancement: fixed)

Opened 9 years ago

Last modified 7 years ago

keepalive@openssh.com

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: protocol Version: 1.2.3
Keywords: Cc: dottedmag, bagder
Blocked By: Blocks:

Description

libssh2 ignores keepalive@… packet type 98 when it should actually send back packet type 100 with 4 zero bytes.

Change History

comment:1 Changed 9 years ago by dottedmag

Well, this packet is openssh extension, so it might be supported as a feature, but ignoring it is definitely not a bug in libssh2.

comment:2 Changed 9 years ago by bagder

This is now turned into a feature-request, but it would be nice to get it...

comment:3 Changed 7 years ago by stuge

  • Component set to protocol

comment:4 Changed 7 years ago by josefsson.org

  • Resolution set to fixed
  • Status changed from new to closed
  • Version set to 1.2.3

This was fixed in 1.2.3. It was a bug in libssh2 to not send back packet type 100, that is required by the RFC for unknown requests.

Note: See TracTickets for help on using tickets.