Ticket #45 (closed defect)

Opened 9 years ago

Last modified 9 years ago

c compiler cannot create executables on ./configure

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: Version:
Keywords: Cc: dottedmag, jehousley
Blocked By: Blocks:

Description

I tried to configure it and got an error

sudo ./configure in /usr/src/libssh2-0.17 directory

...
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.

in config.log, i found :

...
Thread model: posix
gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
configure:3077: $? = 0
configure:3084: gcc -V >&5
gcc: '-V' option must have argument
configure:3087: $? = 1
configure:3110: checking for C compiler default output file name
configure:3137: gcc conftest.c >&5
/usr/bin/ld: crt1.o: No such file: No such file or directory
collect2: ld returned 1 exit status

...
configure: exit 77

thanks
Dan

Change History

comment:1 Changed 9 years ago by dottedmag

Seems to be a problem with your local setup. Please try to compile some other software and see whether it works.

comment:2 Changed 9 years ago by anonymous

Logged In: NO

Ok I found couples of things missing...
I solved my problem with this :

sudo apt-get install build-essential
sudo aptitude install php5-dev php5-cli php-pear buid-essential openssl-dev zlib1g-dev

thanks dottedmag

Dan

comment:3 Changed 9 years ago by jehousley

Originator found and fixed his problem.

Note: See TracTickets for help on using tickets.