Ticket #53 (closed defect)

Opened 9 years ago

Last modified 9 years ago

Cannot compile libssh2-0.14 on a Suse 10 Enterprise Server

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: misc Version:
Keywords: Cc: dfandrich
Blocked By: Blocks:

Description

Hi

I'm trying to compile libssh2-0.14 on a Suse 10 Enterprise Server updated to SP1,.

This is the error:

slc-107:/tmp/libssh2-0.14 # ./configure

checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for socket in -lsocket... no
checking for ceil in -lm... yes
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ANSI C... (cached) none needed
checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking whether make sets $(MAKE)... yes
checking for ranlib... ranlib
checking whether byte ordering is bigendian... no
checking for pkg-config... no
checking for OpenSSL... configure: error: Cannot find OpenSSL's

libcrypto

I have installed openssl and openssl-devel packages and the libraries seems to be well linked:

slc-107:/tmp/libssh2-0.14 # ldconfig -v |grep libcrypto

ldconfig: Can't stat /usr/X11R6/lib64/Xaw3d: No such file or directory
ldconfig: Can't stat /usr/X11R6/lib/Xaw3d: No such file or directory
ldconfig: Can't stat /opt/kde3/lib: No such file or directory
ldconfig: Can't stat /opt/kde3/lib64: No such file or directory
ldconfig: Path `/lib' given more than once
ldconfig: Path `/lib64' given more than once
ldconfig: Path `/usr/lib' given more than once
ldconfig: Path `/usr/lib64' given more than once
libcrypto.so.0.9.8 -> libcrypto.so.0.9.8
libcrypto.so.0.9.7 -> libcrypto.so.0.9.7

I tried to compile the lastest version too but i had the same error.

In this machine i have compiled and installed nrpe (for example) that uses the same libraries without problems.

What can i do?

Thank you very much and sorry for my English ;-)

jmachr@…

Change History

comment:1 Changed 9 years ago by dfandrich

Duplicate of bug #1837516

Note: See TracTickets for help on using tickets.