Ticket #85 (closed defect)

Opened 8 years ago

Last modified 8 years ago

Compile error on FreeBSD

Reported by: anonymous Owned by: bagder
Priority: normal Milestone:
Component: Version:
Keywords: Cc: bagder
Blocked By: Blocks:

Description

OS: FreeBSD Version: 6.2, 6.3, 7.0 (seems as not version depended)

Short descr.: Can't upgrade libssh2 from libssh2-0.18 to libssh2-0.2,1 due to compile error.

Long descr.:
Command "#portupgrade libssh2-0.18" brings to error message:
. . .
===> Building for libssh2-0.2,1
cc -o channel.o channel.c -c -O2 -fno-strict-aliasing -pipe -I/usr/local/include -I/usr/include -Wall -g -I../include/ -fPIC
In file included from channel.c:38:
../include/libssh2_priv.h:181: error: `MD5_DIGEST_LENGTH' undeclared here (not in a function)
../include/libssh2_priv.h:184: error: `SHA_DIGEST_LENGTH' undeclared here (not in a function)
* Error code 1
. . .

Change History

comment:1 Changed 8 years ago by bagder

Whoa, what on earth is the "0.2,1" version? (we don't have any include/libssh2_priv.h file since quite some time)

We've released a 1.0, Try that!

comment:2 Changed 8 years ago by anonymous

The problem was resolved by FreeBSD maintainer.
It was particular FreeBSD problem.

Sorry for disturbance.

Note: See TracTickets for help on using tickets.